Rapoo 7800P Update

On Thursday evening, it started; not one but two orange LEDs under the surface glow whenever I move the mouse. It can only mean one thing. Low batteries. Lose a point for wasting my remaining power flashing lamps at me.

What was it supposed to be? A year? What did I get? Just over two months.

Admittedly, my mouse travels a lot, LOT farther than the "average" user's rodent in the "average" day, and two months is actually more than I expected, certainly on a par with any AA-devouring mouse I've previously owned. I'm actually quite impressed.

And does it take rechargeables? Yup. I've just popped in a couple of Lidl "TRONIC" batteries at around 80% and the mouse is perfectly happy.

Also of note, the mouse worked perfectly right up until the point the batteries died. It just went stop. I wiggle, the amber battery warning LEDs don't come on. Aha. There was none of the juttery-stuttery-get-dem-batteries-looked-out-mate malarkey I'm used to.

So that's about it for the Rapoo "review". Still lovin' it. A couple of addedattheendums..

The scroll wheel gets greasy easy (couldn't resist!). Perhaps it's because of the flatter profile, perhaps it's the rubberoid material, but whatever it is, I need to keep my scrolling fingers free of all oils or else clean the wheel daily (actually a fairly quick and simple operation - angled drag over microfibre with the device switched off) but still, fingers produce oil, so it's a wee bit of an annoyance.

Also, the buttons have proved to be slightly noisy, specifically the side buttons. I often hear tiny tension clicks when I move the mouse around. Nothing too loud or annoying, but there you have it.

Right, back to using the mouse!

for now..

;o) Cor

 ©  2020 « corz.org » 20.4.9  

Welcome to corz.org!

Since switching hosts (I hope you are alright, Ed! Wherever you are …) quite a few things seems to be wonky.

Juggling two energetic boys (of very different ages) on Coronavirus lockdown, I'm unlikely to have them all fixed any time soon. Mail me! to prioritise!